Actualités techniques / 2013 / Semaine 44

From Meta, a Wikimedia project coordination wiki
< Tech‎ | News
Jump to navigation Jump to search
This page is a translated version of the page Tech/News/2013/44 and the translation is 100% complete.
TriangleArrow-Left.svgprécédent 2013, semaine 44 (lundi 28 octobre 2013) suivantTriangleArrow-Right.svg
Other languages:
Deutsch • ‎English • ‎Nederlands • ‎français • ‎polski • ‎português do Brasil • ‎suomi • ‎čeština • ‎русский • ‎українська • ‎বাংলা • ‎中文 • ‎日本語 • ‎한국어

Dernières actualités techniques de la communauté technique Wikimédia. Veuillez informer les autres utilisateurs de ces changements. Certains changements ne vous concernent pas. D’autres traductions sont disponibles.

Nouvelles fonctionnalités

  • Le style et les couleurs des messages d’avertissement, d’erreur et de validation ont été changés dans tous les habillages de MediaWiki. [1]

Nouvelles de l’ÉditeurVisuel

  • Vous pourrez bientôt passer directement de l’ÉditeurVisuel à l’éditeur de code (wikitexte) lorsque vous modifiez une page, sans avoir besoin de publier vos modifications entre temps. Il n’est pas encore possible de faire la transition inverse (du code vers l’éditeur visuel) mais les développeurs espèrent implémenter cette fonctionnalité à l’avenir. [2]

Problèmes

  • Il y a eu un problème technique le 31 octobre dû à l’activation de MediaWiki 1.22wmf2 sur les wikis de test. mediawiki.org a également subi ce dysfonctionnement, de même que le système d’authentification. Si vous avez rencontré des problèmes pour vous connecter avec votre compte, il est probable que cela en soit la cause.

À venir

  • À cause du problème rencontré avec MediaWiki 1.22wmf2, le calendrier de son activation a été modifié. Cette nouvelle version de MediaWiki sera activée sur mediawiki.org et tous les wikis hors de Wikipédia le 4 novembre, et sur toutes les éditions de Wikipédia le 7 novembre.

Développeurs de JavaScript et gadgets

  • Suite à un changement récent, les gadgets et scripts utilisateur qui utilisent jQuery UI doivent maintenant charger les modules nécessaires de façon explicite, car il est possible qu’ils ne soient pas chargés par défaut. [3]
  • Les développeurs ont commencé à supprimer des méthodes qui ont été déclarées comme obsolètes depuis longtemps. Vous devriez vérifier votre console JavaScript (en mode debug=true) et y vérifier la présence d’avertissements d’obsolescence avec leurs traces d’appel. [4]

Actualités techniques préparées par les ambassadeurs techniques et postées par le système global de distribution de messages • Contribuer • Traduire • Obtenir de l’aide • Donner votre avis • S’inscrire ou se désinscrire.