Talk:Flickr2commons

From Meta, a Wikimedia project coordination wiki
Jump to: navigation, search

Contents

Message, Invalid photo ID[edit]

Trying to use the new version: Repeatedly get a "Bad photo ID" pop-up when I use the standard URL for a single photo -- which works fine on the old version. ??? TIA, Tillman (talk) 17:37, 19 November 2012 (UTC)

  • This is a continuing problem, especially now that the old version has disappeared. Same problem as described above: the specific message is "Photo not found", for a valid Flickr URL. Since Bryan's Flickrbot is also broken, this is a major obstacle! TIA for any help, Tillman (talk) 15:46, 30 August 2013 (UTC)
An example URL would be nice... --Magnus Manske (talk) 10:32, 2 September 2013 (UTC)
The problem was, it wasn't clear that you are only to use the "bare" Flickr photo ID# rather than the entire URL (as was used in the previous version). Making this explicit on the form would be helpful. TIA, Tillman (talk) 21:22, 9 September 2013 (UTC)
Added a bit. Other users may want to add directions for the other upload options. --Tillman (talk) 01:25, 10 September 2013 (UTC)

Categories[edit]

Could you add an option to not add automatically any categories to transfered photo? Just the ones that I select, not Flickr tags. Dudek1337 (talk) 22:36, 18 December 2012 (UTC)

Slow[edit]

Today, after 01:30 trying, I managed to upload one image. It just takes forever to connect. What’s wrong? Tuvalkin (talk) 16:09, 27 February 2013 (UTC)

I didn't change anything. If it is slower than usual, or failing, it is most likely a problem with the toolserver (or, less likely, Flickr). --Magnus Manske (talk) 16:13, 27 February 2013 (UTC)

Feature request[edit]

"Max. pictures" is a good idea, but the tool should be able to browse to the "next 50" etc. For larger sets, the tool is hardly usable this way. --AndreasPraefcke (talk) 09:42, 2 April 2013 (UTC)

Another request: Please change "Run" to "Run Search (and delete form entries)" (or make it grey after the first click on it). Maybe I'm stupid but I accidently cleared entries numerous times (actually whenever I haven't visited the tool in a while and have to get used to it again), since one has to go all up to the beginning of the page after finishing editing it, and then the blue "Run" is just too tempting, but it doesn't mean "run" then but "ruin my work". --AndreasPraefcke (talk) 07:59, 30 January 2014 (UTC)

Bug?[edit]

"Add to every description" does not do anything at all. --AndreasPraefcke (talk) 15:11, 2 April 2013 (UTC)

Some images just won't work[edit]

I love the tool (old and new version), but sometimes it just won't work, regardles how often and when you try (and I've tried numerous times for days now). Example: http://www.flickr.com/photos/44112235@N04/8598254378 always produces a result that looks perfectly good (in v1) but there is no upload; and in version 2 there's a red field with "Transfer failed : Upload error" (without further explanation) instead of the usual green field with the link to the new file. What prevents the tool from uploading this? (and everything else in this FlickR set?) Licenses and files seem perfectly o.k. to me. Other uploads work just fine (or at least at second try). --AndreasPraefcke (talk) 15:11, 2 April 2013 (UTC)

Illustration:

Used 116108 times since 2008-04-08
TUSC verification OK.
Checking license ... license OK ({{cc-by-sa-2.0}})
Tags : Lorenz Maroldt, Diskussion, Heinrich-Böll-Stiftung, Reihe „Was ist der Deutsche Traum?“ Vorbilder im Gespräch
Getting image URL ... http://farm9.staticflickr.com/8369/8598254378_8957947396_o.jpg
Used 116109 times since 2008-04-08
Output of upload bot

The image should now be at Lorenz_Maroldt_(8598254378).jpg. Edit the new description page.[[Image:Lorenz Maroldt (8598254378).jpg|thumb|Lorenz Maroldt (8598254378).]]
Now check the new image has good categories!

It's not there, though. --AndreasPraefcke (talk) 11:03, 5 April 2013 (UTC)

User and tag[edit]

Any chance of uploading by "user and tag", like http://www.flickr.com/photos/treeblog/tags/pontfadogoak/ please? Andy Mabbett (Pigsonthewing); Talk to Andy; Andy's edits 16:27, 13 May 2013 (UTC)

Unable to use the tool because it fails when I click "Register TUSC account"[edit]

"Register TUSC account" goes to a Bad Request page. http://tools.wmflabs.org/~magnus/tusc.php Is this still a usable tool? If not, is there a good alternative for moving groups of files from flickr to wiki commons? Please advise, Mary Mark Ockerbloom (talk) 19:38, 10 June 2013 (UTC)

Mass-edit title[edit]

The tool works like a charm, lately. It is particularly useful because it automatically chooses a unique filename (unlike UploadWizard which just crashes) and it checks for duplicates (though not via hash yet) unlike all the other tools, however there is still one thing missing (which I love in Vicuña Uploader) i.e. the possibility to mass rename. Just uploading numbered photos is not particularly appreciated; I would need something as simple as adding a prefix to all filenames. --Nemo 08:13, 18 August 2013 (UTC)

File Overwrite.[edit]

When an image is transferred from Flickr to Commons is F2C able to overwrite a Commons' file of the same name? Saffron Blaze (talk) 04:16, 22 September 2013 (UTC)

"Transfer failed : 500 Internal Server Error"[edit]

Tool doesn't seem to be working today, returning this error message on several trials. --Tillman (talk) 19:39, 13 October 2013 (UTC)

Working again, as of this AM --Tillman (talk) 19:14, 16 October 2013 (UTC)

I have some troubles with this new flickr interface[edit]

Can this picture be uploaded? I think so but the tool keeps telling me that I'm wrong. Thank you. --Luckyz (talk) 12:02, 18 October 2013 (UTC)

It's possible that the page was already uploaded and deleted: there is no freedom of panorama in Italy and that's a recent building. I don't remember if the hash matching checks deleted files too. --Nemo 20:08, 26 October 2013 (UTC)

Flinfo issue 3[edit]

I’m getting this error «Flinfo issue 3», repeatedly, with different images and settings. What does it mean?, what should I do? Tuvalkin (talk) 01:07, 20 November 2013 (UTC)

Same here. Example: http://www.flickr.com/photos/v230gh/4354097448/ --AndreasPraefcke (talk) 18:42, 19 February 2014 (UTC)

I had this error too, but I realized that it was because the Flickr image didn't actually have a compatible license (needs to be cc-by-sa or freer, no commercial restrictions) czar  06:08, 14 April 2014 (UTC)
I've uploaded a set with some 60 photos and maybe a dozen of them fail with this error message, but there isn't an issue with the licenses. Examples 1 and 2. Does anybody know what the problem is? Schwede66 (talk) 21:07, 26 April 2014 (UTC)

Upload sets[edit]

There are problems when uploading sets. It uploads all the photos from a user not just a single set. And it also don't give automatically the ID number of a user when the username is insert.--SunOfErat (talk) 15:33, 20 December 2013 (UTC)

Time limit for filling out the form?[edit]

Is there a maximum time limit on filling out the form? I left the page half filled overnight and now I'm getting "Transfer failed : 500 Internal Server Error". It's taken me hours to fill it out, should I just try again later or is it permanently not going to work?

Mrjohncummings (talk) 13:39, 24 December 2013 (UTC)

Has it stopped working?[edit]

I have used this tool lots of time, but it does not work on my system now. I click to upload, then the pictures are surrounded by light blue, but this does not change to green and the pictures are not uploaded. Any comments? 86.145.178.175 11:55, 7 January 2014 (UTC)

I agree. Magnus, please verify the connection to http://wikipedia.ramselehof.de/flinfo.php - a 500 error is thrown every time.
Firebug screenshot: http://screencast.com/t/5HkXiXwDXTL
Thanks. --Gikü (talk) 14:51, 7 January 2014 (UTC)
I first experienced the same problem as 86.145.178.175 on January 6th, and the problem remains the same today. No photographs from Flickr sets will complete the upload process. Dolovis (talk) 15:00, 7 January 2014 (UTC)

Logged under https://jira.toolserver.org/browse/MAGNUS-392 --Gikü (talk) 15:32, 7 January 2014 (UTC)

Looks like it was fixed. --Gikü (talk) 12:21, 13 January 2014 (UTC)

"Bad Request" Error message after new file created[edit]

Lately this has sppened pretty regularly, most recently after creating File:Menu, Coppa’s Restaurant, San Francisco (12001587454).jpg. Tool appears to create the new file, but when you try to open it, get an error msg instead: "Bad Request Your browser sent a request that this server could not understand."

Workaround: re-enter the Flicker # and run tool again, get a red screen, file then comes up normally. Annoying and time-consuming. Help? --Tillman (talk) 20:23, 21 January 2014 (UTC)

Not working?[edit]

Last three times I've tried (all today, 01/22/14), tool acts like it's created a file, then returns the "No file by this name exists, but you can upload it" error message. Trying the workaround described above just runs you in a circle. Something seems broken. --Tillman (talk) 05:18, 23 January 2014 (UTC)

I've the same problem when I want upload this image. --ComputerHotline (talk) 08:07, 26 January 2014 (UTC)

Transfer failed : 200 OK[edit]

When trying to upload a set of photos, return erroi - "Transfer failed : 200 OK". This is going from a week ago til today JotaCartas (talk) 16:09, 3 March 2014 (UTC)

  • Also not working for me. Error msg: Transfer failed : 500 Internal Server Error. Hasn't worked in about a week. Help? Thx, Tillman (talk) 18:49, 5 March 2014 (UTC)

Doesn't work at all. "Transfer failed : null" everywhere. --AndreasPraefcke (talk) 20:59, 5 March 2014 (UTC)

Still not working. Now the message is Transfer failed : Bad API response[1]: N; --AndreasPraefcke (talk) 18:41, 6 March 2014 (UTC)

Transfer failed : null[edit]

When I want to upload a file, there is this message "Transfer failed : null". Why ? --ComputerHotline (talk) 16:02, 7 March 2014 (UTC)

I get the same message, apparently since the authorization method changed from TUSC to OAuth. Does it work for anybody? darkweasel94 (talk) 10:25, 10 March 2014 (UTC)
Nope, getting it myself now.Morgan Riley (talk) 03:10, 11 March 2014 (UTC)

Should be working now[edit]

Sorry if it was down for a while (I didn't realize), but it should be working at least since a few days ago. If there's an issue, try and re-authorize. Please tell me (with example!) if something doesn't work. --Magnus Manske (talk) 16:49, 12 March 2014 (UTC)

@Magnus Manske: Es funktioniert noch immer nicht. Ich versuche gerade, das Album (photoset) mit der Nummer 72157630358496322 hochzuladen. Ich habe Flickr2Commons bereits neu autorisiert. Meine Einstellungen sind die Standardeinstellungen, außer dass ich nicht automatisch die Kategorien von Flickr übernehme, und dass ich folgende Kategorien für alle Dateien hinzufüge:
[[Category:Files uploaded by darkweasel94 (cleanup)]]
[[Category:Wiener Straßenbahnmuseum]]
Die Fehlermeldung ist wieder "Transfer failed : null". darkweasel94 (talk) 17:00, 12 March 2014 (UTC)
Habe eben in neuem Browser (wegen cache, cookies etc.) mit diesem photoset, ohne auto-cats, probiert. Fehler, da nicht autorisiert. Autorisiert, nochmal probiert, klappt. Habe Autorisiertung-Link jetzt "direkt" gemacht, vielleicht hilft das. Bitte noch mal autorisieren und versuchen! --Magnus Manske (talk) 19:13, 12 March 2014 (UTC)
Ich habe jetzt wiederholt in verschiedenen Reihenfolgen Cache und Cookies gelöscht, autorisiert (mit und ohne Refresh zwischen Autorisierung und Ausfüllen des Formulars). In ungefähr der Hälfte der Fälle habe ich "Transfer failed [1] : null" bekommen, aber manchmal auch: "Transfer failed [1] : Not authorized (bad API response[isAuthOK]: null)". Ich habe es auch in einem Browser probiert, den ich sonst nicht benutze (Safari; sonst verwende ich Firefox Aurora), dort auch die Fehlermeldung mit "null". darkweasel94 (talk) 19:41, 12 March 2014 (UTC)
"null" ist, was die Commons-API ausspuckt; für meinen Geschmack könnte das auch informativer sein... Hat vielleicht mit diesem Bug zu tun. Habe Firefox-Cache&cookies gelöscht - Fehler, nicht autorisiert. Autorisiert - läuft. Ebenso in Chrome. Ist mir ehrlich ein Rätsel, warum das bei euch nicht klappt.
Der Uploader verorgt jetzt auch URL2Commons - vielleicht mal probieren, ob das da klappt? Nur erstmal eine geeignete Datei auf dem Netz finden...
Wer mal ausprobieren will, of OAuth gesamt nicht geht (zumindest über meine Tools), oder nur der Uploader, kann mal in Reasonator oder Autolist das Wikidata-OAuth-Editing probieren.
Tut mir leid, aber mir gehen da langsam die Ideen aus. Wenn ich den gleichen Fehler bekommen würde, könnte ich's wahrscheinlich ausklamüsern, aber so... --Magnus Manske (talk) 21:03, 12 March 2014 (UTC)
CropTool funktioniert bei mir jedenfalls, ich probier einmal das aus, was du vorschlägst. darkweasel94 (talk) 21:13, 12 March 2014 (UTC)
URL2Commons hat ziemlich genau dasselbe Problem wie Flickr2Commons, ich bekomme zuerst, dass ich nicht autorisiert bin, und wenn ich es dann autorisiere (ist das normalerweise jedes Mal extra nötig? Ich habe vorher in die Liste geschaut und da war der OAuth Uploader dabei), bekomme ich "ERROR: null". Mit Wikidata kenne ich mich nicht aus, was genau muss man bei diesen Werkzeugen tun, um testweise irgendetwas zu machen (möglichst ohne viel kaputtzumachen) bzw. wo autorisiert man sie? darkweasel94 (talk) 21:31, 12 March 2014 (UTC)
PS: Falls das wichtig ist, die URL, die ich probiert habe, war [1] (du darfst das zum Testen als cc0 hochladen, es ist mein "Werk"). darkweasel94 (talk) 21:33, 12 March 2014 (UTC)

@Magnus Manske: Appears to not be working again. I'm trying to transfer 9677552436 using all the default settings. It is failing again with Transfer failed [1] : null Zellfaze (talk) 14:07, 13 March 2014 (UTC)

Trying this [2] and I've reauthrised it and still get Transfer failed [1] : null at other times I get a different message. Flickrworker (talk) 15:48, 14 March 2014 (UTC)
Confirm. Has Transfer failed [1] : null error message too. Ilya Voyager (talk) 17:03, 15 March 2014 (UTC)

Ich habe es jetzt auch nochmal mit mehreren Browsern und Cache-Löschung und verschiedenen Accounts ausprobiert: imemr nur "Null". Schade, da das Tool vorher mit TUSC ausgezeichnet funktioniert hat. --AndreasPraefcke (talk) 14:04, 17 March 2014 (UTC)

Well, it appears to have worked for @Zellfaze: in the end, maybe he can tell us how. It works fine for me, even in a "virgin" browser after authorizing. I can't reproduce the error, which means I can't debug it. Did anyone try without any add-ons, cookie-blockers for example? Maybe that's it? --Magnus Manske (talk) 18:37, 18 March 2014 (UTC)
I just tried photoset 72157623625261313, adding [[Category:Files uploaded by darkweasel94 (cleanup)]] to all files, but I selected only the files with the tag "wienerprater". I tried it in a "virgin" Konqueror which I reset to factory settings before trying. Interestingly, I got "Transfer failed [1]: null" for most of them, but for 4482103553 (the third file out of those I uploaded) I got a different error message: "Flinfo issue 1" (not written in bold unlike the other one). darkweasel94 (talk) 18:47, 18 March 2014 (UTC)

OK, I created a new user, and sure enough, it doesn't work. I've filed a bug report. --Magnus Manske (talk) 11:55, 19 March 2014 (UTC)

Yeah sorry about that. After trying it with a few more uploads I just went ahead and uploaded it myself and tagged it accordingly. I wasn't able to get it working the other day though it may have appeared I did. I haven't tried it recently. Zellfaze (talk) 12:15, 19 March 2014 (UTC)

Update: Got a reply for the bug report. Apparently, "normal" users can't upload via URL. It works for me because I'm a Commons admin. I'll have to make a temporary copy of each file on Labs, then upload that. This is gonna be sooooo much fun :-( --Magnus Manske (talk) 14:48, 19 March 2014 (UTC)

OAuth upload fixed[edit]

Dear all, thanks for your patience. Using a magic incantation by Brad Jorsch (Anomie), I finally got the OAuth upload to work, and it should work for everyone now! Previously, I used the MediaWiki API's upload-from-URL function, which (on Commons) is only available to admins (not that the API would tell me that). That's why it worked for me and a few other, but not for most. Now, it is doing the "old-fashioned" upload procedure, which works for everyone. Now, get uploading y'all! --Magnus Manske (talk) 19:02, 20 March 2014 (UTC)

Thank you, works perfectly! :) darkweasel94 (talk) 19:09, 20 March 2014 (UTC)

Well, yes, it works now (thanks!), but I can't see the use of the tool right now. The old procedure had the advantage that the tool automatically verified the license at the time of uploading. Now, the files are in need of another review. And God knows when someone will do that, which means, that the photographers could change the licenses or delete the images in the meantime. The old tool was much better in this respect. --Narrenmarsch (talk) 10:12, 21 March 2014 (UTC) Sorry, I just saw that there is a bot that is supposed to do that. Let's hope it always works. --Narrenmarsch (talk) 10:15, 21 March 2014 (UTC)

User:Narrenmarsch, this is being discussed at Commons:Village_pump#OAuth_Flickr2Commons_Flickrreview_tags. darkweasel94 (talk) 17:37, 21 March 2014 (UTC)

Flinfo issue 4?[edit]

OAuth connected, tried to upload a bunch of photos from https://secure.flickr.com/photos/thehearttruth/sets/72157632704703395/ (US Gov-PD). Uploads do not happen, everything selected highlights red with the not-helpful "Flinfo issue 4" error message. Using Firefox 27. - hahnchen (talk) 00:40, 21 March 2014 (UTC)

I am using the Flinfo tool (not under my control) to get the file description. Upstream error; maybe Flickr user or images blacklisted there? --Magnus Manske (talk) 11:29, 21 March 2014 (UTC)
Turns out it was blacklisted. Would be helpful if the tool reported the Flinfo message instead of "issue 4". Might also be useful to check Flinfo when retrieving the gallery, before the upload. - hahnchen (talk) 16:40, 21 March 2014 (UTC)

Missed adding categories?[edit]

On March 30, I uploaded a large number of images to Commons (see my contribs [3]) and had placed categories to be added to each image. But, when it the transferred, it the categories didn't go through. I did another test today Commons:File:Front of BNY Mellon Center (3583589876).jpg, and the same thing happened.--GrapedApe (talk) 13:31, 5 April 2014 (UTC)

Transfer failed [1] : Warning[edit]

https://www.flickr.com/photos/lge/3942480751 fails. What does that mean? I've now uploaded it with Flickr Upload Bot though. - hahnchen (talk) 17:54, 13 April 2014 (UTC)

Well, I can't tell for sure since you've uploaded it now, so my upload attempt will throw a "duplicate" error. I have improved the error display to contain warning messages; next time this happens, it should be more helpful at to the cause at least. --Magnus Manske (talk) 11:58, 14 April 2014 (UTC)

Borked uploads at commons:Category:Tibi (brand)[edit]

I've been using Flickr2Commons to transfer thousands of fashion photographs from Masaki-H. It has gone quite well. Today however, doing a run of around 300 images to commons:Category:Tibi (brand), it seems to have malformed some images. The file seems to be broken on commons for the following -

I've tried re-uploading them through Flickr2Commons, but it's throwing up the duplicate error. I'll let you take a look at it Magnus, and if you don't spot anything, will request deletion before trying again. - hahnchen (talk) 21:12, 17 April 2014 (UTC)

Oh, this is going to be horrible! Looks like the upload stopped in the middle - the page doesn't exist, was never created, there is no history, and the "raw" file seems to point to the temporary upload path. This should never ever happen, thus I blame MediaWiki/Commons. Try the Commons village pump, they may have seen this before. Tell me if it happens again please! --Magnus Manske (talk) 23:09, 17 April 2014 (UTC)
This should be fixed. - hahnchen (talk) 12:38, 25 April 2014 (UTC)

Fails due to HTTPS issue with Flinfo[edit]

After successfully selecting a single Flickr image in the HTTPS version of the tool (thumbnail and filename are retrieved OK in the lower half of the page), clicking "Transfer selected files to Commons" fails with the following error message in the JavaScript console (on Chromium):

"[blocked] The page at 'https://tools.wmflabs.org/flickr2commons/' was loaded over HTTPS, but ran insecure content from 'http://wikipedia.ramselehof.de/flinfo.php?callback=jQuery[...]': this content should also be loaded over HTTPS."

Switching to the HTTP version avoids this error (although I'm then getting "Flinfo issue 3"; the image I'm trying to transfer is this one).

Regards, HaeB (talk) 06:21, 20 April 2014 (UTC)

Thanks, I've added an auto-redirect to http. And even I don't know what the flinfo issues mean ;-) may be "file exists" or "flickr user is on the blacklist". --Magnus Manske (talk) 17:49, 20 April 2014 (UTC)
Great, thanks! (It would be cool to have it available via HTTPS too, but the redirect is of course much better than the error.) And the Flinfo error simply meant that the image had the wrong license, my fault for not checking (later images from that Flickr stream have a Commons-compatible license, so I assumed this had the same). I have now successfully used the tool for a different image. Grüße, HaeB (talk) 18:54, 20 April 2014 (UTC)

Ignore Duplicate errors[edit]

I speedied some images after they were uploaded with an incorrect filename and description. I tried uploading the corrected versions but flickr2commons still throws up the duplicate error and has no option to ignore it. This would be a welcome option. - hahnchen (talk) 12:38, 25 April 2014 (UTC)

Silent failure?[edit]

I've tried this promising looking tool a couple of times. I've told it to look at the last N items in my photostream, and tried to select fewer than 24 of those images to upload. (Telling the tool to not try to upload the other N-24 images is time-consuming. And I would prefer to select the 24 I want, rather then unselect the N-24 I don't want this time around.)

Having done this I should be able to start the tool working by clicking on "Transfer selected file to commons", correct?

Well, I see a blue bar spread across the screen, but, otherwise, nothing happened. No uploads. Big frustration. Geo Swan (talk) 04:18, 26 April 2014 (UTC)

  • Update: The program worked, on my N+1 invocation. I am not sure what I did differently however. Geo Swan (talk) 04:31, 26 April 2014 (UTC)

The "only show files not linked from commons" feature doesn't work with sets[edit]

The "only show files not linked from commons" feature doesn't work with sets.

Flinfo regularizes the urls, and builds a consistent "source=" field. Flickr2commons doesn't regularize the image URL -- at least not before the initial presentation of images for selection. So, when the user selects all the images from a photostream, the URLs for those images are already in thr proper form, and the "not already linked from commons" comparison is done properly. But, when the user selects all the images from a SET, the URLs are not regulared, prior to the "not already linked from commons" list is built. Geo Swan (talk) 10:00, 26 April 2014 (UTC)

Transfer failed : [1][edit]

I've been having some problems uploading using the user-id + tag combination, but only for some tags, not others.

In each case, the Flickr user-id is 12403504@N02

Tags that failed included:

On the other hand several other tags have worked fine, or 98% fine.

Not sure whether the problem is with the bot or with Flickr (which seems increasingly flaky recently). But for these tags the image-list comes up all right; but then none of them upload properly -- all the boxes turn red, with the error "Transfer failed [1] :"

Any idea what's going on? Jheald (talk) 13:32, 9 May 2014 (UTC)

OK, I think I now know what the problem is: the auto-created filenames are going over 256 characters, which I think is longer than the wiki-software can handle.
Flickr2commons does truncate the filenames; but then it adds the Flickr picture id number, which I think then pushes the name length over the limit. Jheald (talk) 22:23, 9 May 2014 (UTC)
Yes. I can shorten the names by hand & then it works. But a clearer warning message and/or an option for auto-truncation would be nice.
The bot is pretty unforgiving at the moment. For example, I tried to upload some files without a file extension. The bot added ".jpeg", but then the upload failed as a bad filename.
The software also doesn't let you correct small errors & try again. Also if you do try again, (I suspect) this may poison the corrected filenames; because if you then try again from scratch, the bot behaves as if the name is already in use, and adds a "(2)" etc to the end; but then the upload is still rejected as a bad filename. Jheald (talk) 23:49, 9 May 2014 (UTC)
So I changed the names, but it's still complaining. "File:Aikin (1800) 394 - SOM.jpg" ought to be a perfectly good name. However, all but the first file on the list are being rejected. -- forgot to remove the "File:". Back to square one. Jheald (talk) 00:08, 10 May 2014 (UTC)
The Aikin book pics are finally uploaded. So it can be done, but it is a royal pain if the default filenames don't work. Jheald (talk) 10:16, 10 May 2014 (UTC)

Old/new versions of files on Flickr.[edit]

Interesting quirk (bug?) - Flickr2commons is finding different versions of Flickr images compared to the FlickreviewR 2 bot.

For example: this file.

Specifically, Flickr2commons appears to be uploading the original version of images, whereas FlickreviewR 2 is finding the most current version of images on Flickr (and if necessary swapping them in instead).

So, for example, there are many images in the British Library's Flickr stream which have been user-tagged for rotation since they were first uploaded. Flickr2commons appears to be uploading the original (unrotated) image, whereas FlickreviewR 2 is replacing these with current post-rotation images.

Is this useful behaviour (it means we get a fuller audit trail of the history of images)? Or should Flickr2commons be modified to find the same versions that FlickreviewR is finding? Jheald (talk) 10:59, 16 May 2014 (UTC)

I think it's problematic that these two programs work differently, because that means the reviewing bot often has "size_not_found" errors which then require manual human review. darkweasel94 (talk) 11:02, 16 May 2014 (UTC)

"Photoset"[edit]

Flickr now calls this an "Album". Shouldn't we change out UI accordingly? - Jmabel (talk) 19:37, 21 June 2014 (UTC)

What is "user NSID"?[edit]

"Could not identify Flickr user [username]. Please use the user NSID."--Brainy J (talk) 00:37, 4 July 2014 (UTC)

Transfer failed [1] : Warning/badfilename[edit]

Transfer failed [1] : Warning/badfilename: Sanicula_bipinnatifida_Edgewood_preserve_CA.jpg

Why did this one fail? Is there a FAQ for filenames the tool will accept? This has been a constant, random problem lately.

Worked fine for the default name, File:Sanicula bipinnatifida (13385079003).jpg --Tillman (talk) 22:26, 5 August 2014 (UTC)

And another: Transfer failed [1] : Warning/badfilename: Grindelia_stricta_var_angustifolia.jpg --Tillman (talk) 00:59, 7 August 2014 (UTC)

PD-USGov-POTUS vs PD-USGov-DOS[edit]

Yes check.svg Fixed When uploading this file from the DOS's Flickr-stream, Flickr2Commons added {{PD-USGov-POTUS}} when it should have added {{PD-USGov-DOS}}. Josve05a (talk) 18:35, 13 August 2014 (UTC)

Upstream problem, here. --Magnus Manske (talk) 10:24, 4 September 2014 (UTC)

Flickr user Vikalpa | Groundviews | CPA[edit]

I am unable to transfer any photos by Flickr user Vikalpa | Groundviews | CPA even though the photos have an appropriate licence (CC BY 2.0) and have been marked as "Safe". I keep getting an error message "Transfer failed [1] :". Any idea what the problem is?--Obi2canibe (talk) 10:54, 28 September 2014 (UTC)

Which filenames did you choose? If you didn't change them (you can do so in a batch using "prefix selected names") from what they are on Flickr, the title blacklist will prevent you from uploading files with these filenames. darkweasel94 (talk) 11:32, 28 September 2014 (UTC)
Thanks Darkweasel94. I didn't change the files names but now that I've prefixed them it's all worked.--Obi2canibe (talk) 16:22, 28 September 2014 (UTC)

Ease of use[edit]

I am trying to serve the best and easiest way for a GLAM to upload their free images from Flickr to Commons. But I had some problems:

  • The username could not be found. I used the one in the url of the Flickr userpage (ylearkisto), also the longer forms (Yle Arkisto - Yle Archives, and Archives of the Finnish Broadcasting Company Yle). The institution has just been accepted in the Flickr Commons. They have earlier had their images in the ordinary accounts. So this may play a role.
  • I was not able to find any instance of the NSID on the Flickr user pages. I finally found it as part of the "Block this user" -link. It will be difficult to advise the GLAM to try to track it.

So, is there a problem with the name lookup, and what could be done about it? Cheers, Susannaanas (talk) 10:51, 6 October 2014 (UTC)

Transfer failed with set 72157626774706811[edit]

I'm trying to upload photos from set 72157626774706811 (not the whole set, just a few photos from it, but I've loaded the entire set and then selected the images I wanted). I didn't change the descriptions, filenames or individual categories from the tool's suggestions, but I added [[Category:Files uploaded by darkweasel94 (cleanup)]] to all files. All images I've selected fail with "Transfer failed [1] : ". I can't figure out why. Can someone help me? darkweasel94 (talk) 08:29, 17 October 2014 (UTC)

Interface optimalisation[edit]

Hi, so I've been thinking about redesigning the form, since I think some improvements can be made. Especially the visual feedback on only having to fill in one of the first three input fields in the beginning. I discussed this with my interaction design teacher and after explaining what the tool is for and walking him through the process he had this to say:

Your ideas about the problems with the beginning of the form (OR, etc.) are basically correct. It might not be a very big problem, but there are better ways to design it.

Most of the problems in the form have to do with visual hierarchy and feedforward. The way to tackle this is to go through the book Web Form Design - filling in the blanks by Luke Wroblewski and just apply the principles. There are a few quick wins, I think. But you have to sketch out new solutions. So for example: Adding in explanatory texts where you can automate revealing of categories. Or better labels in the beginning: 'To log in, just fill in ONE Of the fields below:' (then the four fields, indented) An inline validation would then be handy (green checkmark appears behind field that's filled in) as feedback. That sort of thing. It's all pretty well-known stuff. You should also test it to find out how big a problem this all is. So for example, maybe people don't really have such a big problem with the 'OR's' in the beginning. It looks basically good to me!

It's just a question of fine-tuning it - applying the principles of form design that Wroblewski and Carolyn Jarrett have figured out.

My initial thought on improving the interface is to have it more clearly a second step to fill in the last two of the initial 5 input fields. The first three are a group, and there should be more distinct than the latter two. --Vera (talk) 21:21, 3 November 2014 (UTC)

Cannot transfer files after badfilename error; upload naming feature suggestions[edit]

Transfer failed [1] : Warning/badfilename: Misaki-uma_May_2014_DSC_4701_(14220601542).jpg

What, because it still contains DSC_####? Well, even after I fix the names I can't transfer the files since they can't be re-selected since the little tick-boxes are gone. So I have to run again and do everything a second time. Anyways.

Suggestion time
  1. To make handling large, unhelpfully tagged photo streams much easier, a "only run through images [number range] in given feed" type of setting.
  2. A "reduce all file names" feat that replaces anything and everything down to a running set number and the suffix, as in 0001.JPG. User should be able to decree where the numbers start. This with the prefix adding feat that's already there and which I dearly love would make naming even large sets from scratch very efficient.

--Pitke (talk) 08:56, 10 November 2014 (UTC)

Feature request, able to upload from Flickr groups[edit]

Hi

I'd really love if this tool could transfer images from a Flickr group, these tend to have very good images, some of which may be under a Wikipedia compatible license.

Thanks

Mrjohncummings (talk) 18:17, 15 November 2014 (UTC)

Recovery after failure[edit]

After failing to upload one or more images from a set (section turns red), right now we have to re-select the set before we can try again to upload those images. Given that most failures are recoverable, this seems like poor interface. It really ought to be possible to just reselect the image(s) and retry. - Jmabel (talk) 02:02, 20 November 2014 (UTC)

Transfer failed[edit]

I am getting an error that says "Transfer failed [1]:" with nothing after the colon when I try to transfer this file [4]. I have used this tool a number of times, but haven't had this issue. Fredlyfish4 (talk) 21:16, 9 December 2014 (UTC)

Database error during authorisation[edit]

Thanks for this tool. It saves a LOT of time! When I tried to use it just now, I had trouble authorising. I receive the following message on this page:

Database error

A database query error has occurred. This may indicate a bug in the software.

Function: MediaWiki\Extensions\OAuth\MWOAuthConsumer::newFromKey

Error: 1054 Unknown column 'oarc_callback_is_prefix' in 'field list' (10.64.16.24)

What could be causing this?--Cpt.a.haddock (talk) 13:24, 11 December 2014 (UTC)

Authorisation[edit]

Its great for loading individual images but I am outraged again from the last 3? hours of being blocked for each upload for being unauthorised and there seems to be no alternative at all to re-entering Everything. Yes, it says reload - doesn't work for me never has. Please understand I am squealing like this because it is so-o-o maddening - why is it done to me? Tell us the permissible delay and I can make a guess as to whether or not I might be thrown out. It is as if it is designed to infuriate though I am sure it is not. Eddaido (talk) 09:50, 11 March 2015 (UTC)

Asking for new funcionality - add Flickr Tags[edit]

Great tool! I propose a new feature that would allow to add all the tags of the photo in the Flickr, to the description of it in the Commons. Most of the time, the photos as none or very few descriptions, and the title is not always very descriptive. This wold help with better categorization to be made in the future by others users. Ex. File:DSC 1939 (4707706029).jpg. This is mainly important when we upload a photoset with a great number of photos. Thank you. --JotaCartas (talk) 14:41, 22 April 2015 (UTC)

Duplicate image notification[edit]

When I am transferring files to commons, I don't see the duplicate file error notification until the transfer is almost complete. Can this notification come earlier in the process, such as when I put in the Flickr photo ID? Epic Genius (talk) 16:34, 24 April 2015 (UTC)

It sort-of does notify you, with a tiny triangle to right of box. Could be made more prominent. --Tillman (talk) 20:59, 13 July 2015 (UTC)

Backlinks and HTTPS[edit]

When the tool uploads files to Commons it adds a backlink to Flickr in the source field of the information template using a HTTPS URL. However, when it is looking for backlinks (as part of the "Show only files not linked from Commons" functionality) it only seems to recognise HTTP URLs and not HTTPS URLs. It would help if the tool could recognise both forms of URL so all files linked from Commons could be filtered out. - AdamBMorgan (talk) 13:18, 24 June 2015 (UTC)

Categories not adding to uploaded image page[edit]

For the past couple of days, categories that I add in the Categories box, don't appear in the uploaded image page. A nuisance. Please fix! Thanks, Tillman (talk) 00:08, 4 July 2015 (UTC)

Still no categories. HELP? TIA, Tillman (talk) 20:57, 13 July 2015 (UTC)
And still not working. Anyone here? Help? --Tillman (talk) 19:44, 19 July 2015 (UTC)

Transfer failed [1] :[edit]

Any idea why I get "Transfer failed [1] :" with the red box and no error message whenever I try to upload any image from [5]? They're cc-by-2.0 so license should be fine. I'm able to transfer other photos just fine. Replicated this across Chrome and Firefox. Help? czar  22:06, 8 July 2015 (UTC)

@Magnus Manske, is it an issue with OAuth, as above? – czar 22:09, 8 July 2015 (UTC)
Now displaying better error message. File ending/mime type mismatch. Change file name ending to ".png" and it works. --Magnus Manske (talk) 15:37, 4 August 2015 (UTC)

{{Location dec|0.000000|0.000000|source:Flickr}}[edit]

There are several files on Commons that have been tranfsered by this tool and contain the mentioned default location. It seems that the original picture did not contain location data. Do you know where this comes from? Can we remove the template from these files? --Aschroet (talk) 19:41, 15 July 2015 (UTC)

Although someone fixed these issues it is worth to check if the script wrongly inserts the default location in some cases. --Aschroet (talk) 15:35, 22 July 2015 (UTC)

Public domain[edit]

This tool is not work for the public domain pictures on Flickr. Please fix it. Thank!--Paris 16 (talk) 17:11, 21 July 2015 (UTC)

Tell me the license ID for "public domain" and I'll be happy to add it. So far, I allow 4,5,6,8. --Magnus Manske (talk) 15:39, 4 August 2015 (UTC)